This project is read-only.

Error: Microsoft.SharePoint.SPException: User cannot be found.

Jul 16, 2013 at 2:54 PM
Good morning,

Running the script, I am getting the following error:

- Creating Site Collection "http://Portal.WGSHouse.com.br"...

  • Script halted!
Exception : Microsoft.SharePoint.SPException: User cannot be found.
                       at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database,
                    SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32
                    nLCID, Int32 compatibilityLevel, String webTemplate, String ownerLogin, String ownerName,
                    String ownerEmail, String secondaryContactLogin, String secondaryContactName, String
                    secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean
                    useHostHeaderAsSiteName, Boolean overrideCompatibilityRestriction)
                       at Microsoft.SharePoint.PowerShell.SPCmdletNewSite.CreateDataObject()
                       at Microsoft.SharePoint.PowerShell.SPNewCmdletBase`1.InternalProcessRecord()
                       at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord()
TargetObject : Microsoft.SharePoint.PowerShell.SPCmdletNewSite
CategoryInfo : InvalidData: (Microsoft.Share...SPCmdletNewSite:SPCmdletNewSite) [New-SPSite], SPException
FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSite
ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
ScriptStackTrace : at CreateWebApp, C:\Temp\AutoSPInstaller\AutoSPInstallerFunctions.ps1: line 2220
                    at CreateWebApplications, C:\Temp\AutoSPInstaller\AutoSPInstallerFunctions.ps1: line 2074
                    at Setup-Farm, C:\Temp\AutoSPInstaller\AutoSPInstallerMain.ps1: line 190
                    at <ScriptBlock>, C:\Temp\AutoSPInstaller\AutoSPInstallerMain.ps1: line 358
                    at <ScriptBlock>, <No file>: line 1
PipelineIterationInfo : {}
PSMessageDetails :
Jul 16, 2013 at 10:07 PM
Hey,

Make sure that all of your site collection owners exist.

Ivan
Marked as answer by IvanJosipovic on 1/3/2014 at 1:42 PM